New apps won't load

Incident Report for Streamlit Cloud

Resolved

This incident has been resolved.
Posted Apr 14, 2026 - 10:14 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 14, 2026 - 10:11 UTC

Update

We put a fix in place which sped up the operation. The service should resume in the next 10-15 minutes.
Posted Apr 14, 2026 - 10:11 UTC

Identified

Newly deployed apps won't load due to service overload. We are working on a fix to reduce the load and allow new apps to get deployed.
Posted Apr 14, 2026 - 10:00 UTC
This incident affected: App Deploys.