Applications are not updated when new commits are pushed to the repository

Incident Report for Streamlit Cloud

Resolved

This incident has been resolved.
Posted Jan 06, 2026 - 15:43 UTC

Investigating

We are currently investigating the issue. You can work around the problem by restarting the application.
Posted Jan 06, 2026 - 12:34 UTC
This incident affected: Apps.